Author Topic: YT vids on Frontpage  (Read 258 times)

Jubal

  • Megadux
    Executive Officer
  • Posts: 22089
  • Karma: 99
  • Awards Awarded for oustanding services to Exilian!
    • View Profile
    • Awards
YT vids on Frontpage
« on: December 04, 2016, 11:55:26 PM »
I can't seem to get YouTube embedded videos to display when viewing the front page. Does anyone else find this, or is this something weird that's just happening to me? If it's a general issue we should really fix it, being able to get frontpage video content working is fairly super vital.
The duke, the wanderer, the philosopher, the mariner, the warrior, the strategist, the storyteller, the wizard, the wayfarer...

Glaurung

  • Basileus
    Head of Staff
  • Posts: 2251
  • Karma: 11
    • View Profile
    • Awards
Re: YT vids on Frontpage
« Reply #1 on: December 05, 2016, 08:11:50 AM »
I think it's a general issue - the video of your LIFE game shows up, and runs, correctly when I view the November "Updates from the Forge" as a forum post, but it's just a blank space of the right size in the content on the front page. I think the problem is how the youtube BBCode tags get converted to HTML - in both the forum post and on the front page, the video link appears as:
Code: [Select]
<div class="oharaEmbed youtube" id="oh_qiY8aU7RMoI" style="width: 480px; height: 270px;"></div>
I would guess that in the forum, the CSS (or some other feature) provides the actual link to the YouTube video, while the (separate) front page CSS doesn't do this.

Jubal

  • Megadux
    Executive Officer
  • Posts: 22089
  • Karma: 99
  • Awards Awarded for oustanding services to Exilian!
    • View Profile
    • Awards
Re: YT vids on Frontpage
« Reply #2 on: December 05, 2016, 12:08:41 PM »
I'm sure they used to work once upon a time... hm. :/
The duke, the wanderer, the philosopher, the mariner, the warrior, the strategist, the storyteller, the wizard, the wayfarer...

Glaurung

  • Basileus
    Head of Staff
  • Posts: 2251
  • Karma: 11
    • View Profile
    • Awards
Re: YT vids on Frontpage
« Reply #3 on: December 05, 2016, 02:00:23 PM »
One other, more minor point: the "Updates from the Forge" banner doesn't always fit completely on the front page - I think this depends on the screen resolution. On my home desktop screen (1280 x 1024 pixels), the banner is truncated on the right - I lose half the 'g' and the final 'e'. On my laptop (1366 x 768 pixels), it fits almost completely. On both screens, the banner fits when I view the post in the forum. It would be good if the front page could resize the image to fit the space available.